Login Issues
Incident Report for ThoughtTrace
Resolved
The login issues have been resolved. We will continue monitoring the system for further problems
Posted Aug 19, 2021 - 17:44 CDT
Investigating
We are currently investigating reports of login issues for our apps.
Posted Aug 19, 2021 - 17:23 CDT
This incident affected: Legacy Systems (Provision Insights Web/API, Document Insights Web/API) and ThoughtTrace Platform (ThoughtTrace Web App).