Application Login Issue
Incident Report for ThoughtTrace
Resolved
Our authentication service seems to be functioning as normal again. If you encounter any other issues, please contact our Customer Care team at support@thoughttrace.com.
Posted Feb 04, 2020 - 14:06 CST
Investigating
We are aware of an issue with our authentication service that is keeping users from being able to login to the platform. We are working with the vendor of the authentication service to have it operational as soon as possible.
Posted Feb 04, 2020 - 13:53 CST