Extended Maintenance

Incident Report for ThoughtTrace

Resolved

This incident has been resolved.
Posted Apr 15, 2023 - 17:42 CDT

Update

We are continuing to work on a fix for this issue.
Posted Apr 15, 2023 - 17:29 CDT

Identified

The system is still undergoing maintenance
Posted Apr 15, 2023 - 14:56 CDT
This incident affected: ThoughtTrace Platform (ThoughtTrace Web App, AI Processing).